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Inquiries may be submitted using the Questions window.
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Presented by:



Inquiries may be submitted using the Questions window.



eMedApps - About Us

eMedApps is a Healthcare Information Technology Services company providing practices, 

clinics and hospitals with a full range of services, as well as a suite of products designed to 

increase efficiency and facilitate communication.

• Founded in 1999

• Working as partner with NextGen since 2001

• Worked as subcontractor for NextGen

• Serving healthcare clients across USA

• Services and Products for NextGen clients



Follow Us!

Be sure to follow us on Facebook, Instagram, Twitter and LinkedIn 

and Subscribe to our YouTube Channel! Just search eMedApps 

https://www.youtube.com/channel/UCjRKsJ3Zs5n1dZaeKR5rOVA?view_as=subscriber
https://www.linkedin.com/company/1129816/admin/
https://twitter.com/emedapps?lang=en
https://www.instagram.com/emedapps/
https://www.facebook.com/emedapps/?tn-str=k*F
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About our Presenter

Yvette Bujak 
Yvette has 14 years of experience with 
the NextGen product and is NextGen 
certified in EPM, EMR, Patient Portal, 
and ICS. She has over 17 years of 
experience in the healthcare industry. 
She is typically responsible for 
implementation, project management, 
template development, workflow 
design, training and support of the 
NextGen EHR product. 

Fun Fact! Yvette placed 1st in the 1999 
Junior Olympics for Judo 



About our Presenter

Fred Weinshenk 
Fred has over 20 years of experience as a Systems & 

Infrastructure Engineer. He has a Bachelors in Computer 

Information Systems. He's been with eMedApps for almost 3 

years and is typically responsible for our Hosting Platform 

Implementations & Server Migrations. 

When he's outside of work, he enjoys reading and spending 

time with his two Dogs Micky and ManMan.



Best Practice 

Configuration & 

Automation 



Agenda

• Review some tips and recommendations within NextGen 

that the Practice maybe completing manually. Items will 

include Background Business Processor (BBP), NextGen 

Commination Services (NCS), and Offline Document 

Processor (ODP). We will be reviewing application 

configuration as well as NextGen settings that can help 

achieve automation. 



NextGen Communication Services (NCS)



What is NCS? 

A practice’s NextGen Enterprise applications exchange prescription 

information with NextGen servers and Surescripts through Nextgen 

Communication Services (NCS). The types of data include: 

• Electronic prescriptions (retail and mail order) 

• Pharmacy prescription requests 

• Provider information 

• Pharmacy details 

• Pre Medfusion Portal messages (version 6.2020 and below) 



How NCS work for ePrescribing  

1. Based on the configurations each NCS processor for NextGen ePrescribing 
periodically processes and pulls data from respective ePrescribing tables for 
export to the NextGen Production eRx server. The NextGen Production eRx 
server then routes these ePrescribing messages to Surescripts. 

2. Similarly, NCS periodically checks the NextGen eRx database and transfers 
any new data inbound. Items like prescription refills and eRx errors. 

3. Additional processes handled by NCS include updating the client pharmacy 
file. Clients can import and download new or updated Surescripts 
participating pharmacies into the database.   

4. For Supported patient savings programs, NCS processors are used to 
transmit eligibility requests to and retrieve response messages from external 
partners. If a patient is enrolled in a program or provided materials, NCS is 
used to transmit the enrollment and prescription information to the 
program pharmacy. 



How to Restart NCS? 

1. Log into the 
server where 
NCS is installed 

2. If the NCS 
interface window 
is open, close it 

3. On the server 
Start > Run > 
Services.MSC 

Many times, issues can be resolved by restarting 

NCS. 



How to Restart NCS? 

4. Right Click the NextGen Message Relay > Stop (this will 

also stop the NextGen Queue Processing Service) 



How to Restart NCS? 

5. Right Click the NextGen Queue Processing Service > 

START (This will also start the NextGen Message Relay)



How to Restart NCS? 

6. Launch the NCS 
Application

7. Click on the “Poll 
Now” button  

• When you click “Poll 
Now” You will see 
each Queue 
Processor begin 
connecting. 

• You will see the 
number of completed 
transactions and 
failed. If transactions 
continue to fail 
further investigation 
may be required. 



Automatic Pharmacy Download

• Within NCS NextGen has the ability to automatically 

download pharmacies into NextGen. To do so navigate to 

your server you have NCS installed. Usually your 

communication server. 

• Available in versions 5.9 and up



Automatic Pharmacy Download

Once NCS is launched 

• Stop all services

• Select settings, if a 

password is set, please 

enter your password

• Click Next till you reach 

the configuration screen



Automatic Pharmacy Download

• Within the configuration screen 
expand ePrescribing – Retail 

• Check ePrescribing Retail 
Pharmacy Download

• Under Retail Message 
Processing set the following to 
True: 
– AutoMatch

• This will allow newly 
downloaded pharmacy's to be 
auto match to pharmacy that 
already exists in your system.

– ImportNewPharmacy 

• This will allow new pharmacy 
to be downloaded when they 
become available  



Automatic Pharmacy Download
When setting the 
ImportNewPharmacies = TRUE, 
all pharmacies searched in 
NextGen File Maintenance 
under the Bulk Pharmacy 
Search within the Pharmacy 
download will be downloaded. 
Every pharmacy within the 
selected zip code and radius 
will download.

File Maintenance > File > 
Download Pharmacy 



Allow Users to Download Pharmacy 

Save time and give your clinical staff access to download any 

missing pharmacies. 



Background Business Processor (BBP)



Background Business Processor (BBP)
The NextGen BBP is intended to assist you in scheduling packages (tasks that require manual execution) for 
automatic completion. For example, you can create a package that automatically generates and prints the Daily 
Balance report at the end of each day. You can also configure the NextGen BBP to send a notification email after it 
completes an automated NextGen Enterprise PM process. You can automate the following NextGen Enterprise PM 
processes:

• Reports

• Statements

• Billing encounters

• Claims generation

• Collection and Recall letter generation

• Directory Import

• Stored procedures

• Person merge processing

• RTS eligibility and claim status requests

• RTS eligibility responses

• In addition, NextGen BBP can run NextGen Enterprise EHR and NextGen Enterprise PM memorized reports.

• Inbound Faxing 



Background Business Processor (BBP)

The BBP can automate many daily tasks most common uses 
are: 

• Exporting reports to a shared drive 
– Try to export reports to shared drives vs personal. Folders can be 

protected on shared drives. 

• Emailing reports to specific users or groups 
– If emailing reports best practice is to use distribution lists to cut down on 

maintenance 

• Printing specific reports, statements, recall letters, etc.. on 
a schedule so they are not missed. 



Background Business Processor (BBP)

BBP setup and requirements 

are generally unique to the 

enterprise, the amount of data 

needed to be processed, the 

number of required BBP 

processes, and workflow that 

may be specific and unique to 

the individual practice utilizing 

the tools. 



Background Business Processor (BBP)

BBP Packages can be classified into four district categories in 

terms of processing needs

Severity Description 

Severe A package that results two or more hours of duration 

for the package. 

Heavy A package that results in less than two hours but 

greater than one hour of duration for the package. 

Moderate A package that results in less than one hour but greater 

than thirty minutes of execution for the package. 

Light A standard package that results in less than thirty 

minutes of processing time to complete 



Background Business Processor (BBP)

How often the package is scheduled can also have an impact 

on processing load. 

• A Statement job that is only scheduled once a month will 

have a much higher category than a Statement job that is 

scheduled every day due to package having to 

print/export 30 days of statements at one time. 

• A package of memorized month end reports will have a 

higher category than a package of weekly reports. 



Background Business Processor (BBP)

Job Type Name Daily Weekly Monthly 

997 Directory 

Import 

Light Moderate Heavy 

Account Collection 

Letters 

Light Moderate Heavy 

Batch Posting Heavy Severe Severe

Bill Encounters Heavy Severe Severe

ERA Directory 

Import 

Heavy Severe Severe

Person Merge Severe Severe Severe

RTS Moderate Heavy Severe

Below is a current list of BBP jobs and their typical processing load.



Background Business Processor (BBP)

The following diagram 

provides an overview of 

how the NextGen 

Background Business 

Processor (BBP) 

components work 

together 



Background Business Processor (BBP)

BBP System Requirements 

• BBP server process requirement are as follows: 
– For Light to Moderate process categories, and for packages that do not run on the 

Report Server process, the following hardware requirements apply: 

• Single Processor, 2GB Memory, and any supported operating system in Legacy 
Mode (x32 bit) 

– For processes categorized as Heavy or Severe, and for packages that target or require 
Report Server processes, the with the NextGen Application requirements: 

• Dual Core Processor, 4GB Memory, any supported operating system in Legacy 
Mode (x32 bit) 

– .NET Framework v4.6.2 

• Additional Servers can be added as needed to handle the job loads 



Background Business Processor (BBP)

Note: Nextgen requires that PM (and by extension BBP) run 

in 32-bit mode. This does not mean that you cannot install 

BBP on a 64-bit platform. However, when installed on a 64-

but system, BBP runs in 32-bit legacy mode. 

You can also run BBP server on virtual servers. If you have a 

machine running multiple virtual servers, then each instance 

of the virtual server must meet the preceding requirements. 



Background Business Processor (BBP)

NOTE: The computer running the NextGen BBP Engine Service must stay on 24 hours a day – or, 
at least, it must be running during all times when NextGen Practice Management processes are 
scheduled to execute. If the BBP Engine Service is not active during a scheduled process 
execution, the process cannot run. If the computer onto which you install the BBP Engine Service 
regularly shuts down and reboots, set the service to start automatically.

Recommendation: When installing the NextGen BBP Service Engine, be mindful of the user 
account with which the BBP Engine service logs on. If the password of the user account changes, 
then the BBP Engine service cannot function. NextGen recommends that you create a network 
“NextGen BBP User” account that has the appropriate permissions and a password that does not 
expire. This network “NextGen BBP User” must:

• Have rights to log on as a Windows service

• Have the same printers installed that the person who is setting up the NextGen BBP jobs has 
installed

• Have access to the network locations (if any) specified in the NextGen BBP Jobs.



Background Business Processor (BBP)

You can configure BBP to send email notification when 
packages processing succeeds, fails, or completes. You can 
also set BBP to email exported files and reports as 
attachment to specified recipients. 

The fails can be sent to the IT Department for 
troubleshooting. If you have a ticketing system where a ticket 
can be generated from an email this would be a great email 
to use. 



Background Business Processor (BBP)

1. From the File menu, select E-Mail Setting
– Notification ‘From’ address field, enter the email address from which NextGen BPP 

sends emails. This is a required but “dummy” address that indicates the sender of 

the email. Example: NextGenBBP@yourcomapny.com



Background Business Processor (BBP)

Once email has 
been configured 
you can set 
notifications emails 
for each job and 
can also export and 
send memorized 
reports as 
attachments to 
email recipients 



Background Business Processor (BBP)

Scheduling Requirement Recommendations 

• Multiple jobs scheduled for each package always run sequentially and 
never overlap 

• Package schedules are based on optimum network and database 
availability 

• Scheduling guidelines are based on an operating schedule that runs 
during off business hours 

• Optimum scheduling is unique and distinct to the practice. The use of 
BBP services is accounted for on a 24 hour or “during operational 
hours” schedule as negative impact to network and database 
performance can be impacted severely depending on a variety of 
factors. 



Background Business Processor (BBP)

The recommended schedule guideline 

requirements are: 

• No more than two instances of EPM run at the 

same time on the same machine to prevent 

placing maximum load on processing capacity. 

This is based on the hardware guidelines 

outlined previously) 

• No more the one BBP package schedule to run 

at a given time per BBP server available. 



Background Business Processor (BBP)

• Troubleshoot / 
Monitor BBP 
Packages

• Can use to review 
how long Jobs are 
taking to Run



Background Business Processor (BBP)

Other Database activity 

• Another factor in scheduling jobs 
is to ensure that hey also do not 
overlap with SQL Server jobs 
(Daily Maintenance, Weekly 
Maintenance, or Backups) which 
themselves are also database 
intensive. Your IT staff or DBA 
can give you the schedule that 
the SQL jobs run on. 



Background Business Processor (BBP)

Report Server 

• Using the Report Server to run 
memorized report jobs is a good option 
for reducing database activity on the 
production database. The Report Server 
users its own database, which –
depending your setup – is usually 
updated each night from production. 
This can enable you to schedule some 
report jobs during peak business hours. 
You IT staff or DBA can give you the 
schedule that how when the production 
database gets copied to the report 
server database. 



Offline Document Processor (ODP)



Offline Document Processor

Offline Document Processor
– Tool to assist with document 

generation from the EHR

• Decreases time spent in EHR 

per visit

• Increases speed at which 

clinical documents are 

generated

• A large practice can run 

multiple instances on a 

single server or multiple 

servers 



Offline Document Processor

• Offline Document Processor
– What: “Behind the scenes” document generator

– Who: Used by end users completing typical workflow

– Where: Kept running on a server or standalone workstation

– When: Utilized to generate documents from the EHR from some 

templates or the Document Module

– How: An administrator would set up the program and monitor it to ensure 

it is running during EHR visits.  



Offline Document Processor

In the next couple of slides, we will go over two options of 
running the ODP on a server. 

• The first option is setting up a task scheduler. This is 
recommended so you can ensure that the ODP is always 
running. There is no reason to start the ODP manually and 
if forgotten will not disrupt the clinic workflow. 

• The second option is running it manually. With this option 
you will need to make sure to run the service each time 
the server is restarted. 



Offline Document Processor

Below are detailed instructions for configuring the Offline Document Processor (ODP) to generate 
automatically on a workstation using the Task Scheduler.

Note:  It is important to understand this does not mean “as a Windows service.”  The process is still 
configured to run in a locked Windows user session.

1. Create a dedicated “DocGen” Windows account.
– Most organizations prefer to run the ODP within a Windows user session created specifically for the ODP, which makes 

auditing/troubleshooting easier.  For example, an organization called NextGen Family Practice may create a Windows 
account in their domain called “DocGen_NFP ”.  If such an account does not exist, it is advised to create one.  

– Make sure whatever account will be used, has Local Administrator permissions, as well as read/write/modify permissions 
to C:\NextGen and \\NGRoot. 

2. Determine the appropriate executable to run. 
– There are two Offline Document Processors, one for each of the document generators used within NextGen – High Edit 

(BatchDoc.exe), and TX Text (EMR DocProc.exe).

– BatchDoc.exe is for High Edit documents (generally 7.X KBM)

– EMR DocProc.exe is for TX Text documents (generally 8.X KBM and higher)

– CAVEAT – it is possible to “convert” from High Edit to TX Text before upgrading to the latest 8.x-series KBM.  If this 
applies, please be sure to run EMR DocProc.exe



Offline Document Processor

3. Create a desktop shortcut to the ODP (optional; for 

quicker on-demand access).
– Log on to the dedicated ODP workstation as the DocGen user from Step 

1.  (Note – the rest of this guide must be completed while logged in as 

the DocGen user ). 

– Browse to the C:\NextGen folder.

– Find the appropriate ODP executable (based on Step 2).

– Right click on the executable and select Send to > Desktop (create 

shortcut).



Offline Document Processor

4. Create a batch file to stop/restart the executable
– Open Notepad.

– Copy and paste the below text based on the appropriate executable version.

– For BatchDoc.exe (make sure to update the enterprise and practice IDs as needed)

• @echo off

• taskkill.exe /IM BatchDoc.exe /f

• start c:\NextGen\BatchDoc.exe -enterprise 00001 -practice 0001 -user 0 -maxdocs 0

– For EMR DocProc :

• @echo off

• taskkill.exe /IM "emr docproc.exe" /f

• start c:\NextGen\"emr docproc.exe"

– Go to File > Save As

– Change the path in the Address Bar to the following: C:\Windows\system32 

– Expand the drop-down menu next to Save as type:  and select All Files (*.*) 

– Name the batch file DocGen_Restart.bat (the “.bat ” is important!) and save it.



Offline Document Processor

5. To test the batch file:
– As with any software project, it is always a good idea to test the solution 

before setting it live. 

– Make sure the SetDB utility is configured for the appropriate database 
(e.g. NGProd).

– Navigate to Start > Run

– Type in C:\Windows\system32\DocGen_Restart.bat and click OK.

– Make sure the applicable ODP program starts. 

– If so, continue to Step 6.  Otherwise, troubleshoot why the ODP did not 
start.

– If desired, leave the ODP running so it can process documents.



Offline Document Processor

6. To Create a Scheduled Task to run the batch file automatically follow the steps below:
– Open the Start menu and navigate to All Programs > Accessories > System Tools > Task Scheduler

– In the Actions pane on the right, click Create Basic Task...

• Name = DocGen Restart

• Description = Stops and restarts the ODP

• Click Next.

• Select the Daily radio button.

• Click Next.

• Set the start time to 5:00AM, Recur every:  1 day.  This start time should be relatively close to the office’s opening time, so as to avoid stopping the 
ODP while yesterday’s documents are still processing. 

• NOTE - this should not occur anymore frequently than once daily!  If the task is killed during the day, any documents that are in progress will fail to 
complete and will not appear in the patient's chart.  

• Click Next.

• Select the Start a program radio button.

• Click Next.

• Type the following in the Program/script field – C:\Windows\system32\DocGen_Restart.bat

• Click Next.

• Check the box to Open the Properties dialog box.

• Select Finish.

• NOTE - On the General tab, make sure Security option is set to "Run only when user is logged on."  This will not work properly otherwise!

• Click Ok.

• You have successfully created a scheduled task that will stop and restart the Offline Document Processor. 

• Note:  Do not log off from the DocGen user Windows session.  Disconnect the RDP session (if accessed remotely) or lock the 
workstation.



Offline Document Processor

7. Configure the DocGen Windows Account to Autologon on Reboot, and 
launch EMR DocProc automatically:
– To start EMR DocProc on login 

• Copy the Shortcut from (From Step 3) and paste it in the DocGen user's startup folder.

• The startup folder is user specific, so while logged as the DocGen paste the below path in 
the run promtp"%appdata%\Microsoft\Windows\Start Menu\Programs\Startup"

– To Auto Login on Reboot

• Download Autologon from Microsoft Sysinternals

• Extract the zip file

• Double Click autologon.exe 

• Enter the DocGen Users credentials

• Select "Enable"

• A Message will pop up stating "Auto login successfully configured" 



Offline Document Processor

To run the ODP manually: 

1. Log into server or workstation 

2. Go to C:\NextGen

3. Launch EMR Docproc

Note: The server must be 
running, and you cannot logout 
of the account that the ODP is 
running on. If the account is 
logged off or the server is 
restarted, then the ODP must be 
restarted. 



Offline Document Processor

• Document Queue uses basically the same software as areal-

time document generation and has similar requirements to 

NextGen Enterprise EHR. 

• You should not run multiple instances of EMR DocProc.exe on 

the same machine 

• If a single instance of the Document Queue is not sufficient to 

handle practice typical offline document volume, it is acceptable 

to launch additional instance on separate workstations, if each 

workstation only has a single instance running. 



Offline Document Processor



Offline Document Processor

• Set up must be done in the 
EHRR on the Document 
Configuration System 
Template and an instance of 
ODP must be running on a 
server. 

• In NextGen go to File > 
System / Practice Template > 
Framework Content > 
Document Configuration 



Offline Document Processor

• Set Chart Note to Offline document generation – Configures the option to 
generate the Chart Note offline. If you clear this option, the Chart Note document 
gets generated normally. This check box is disabled if you select Disable Chart 
Note generation option. 

• Set Master document to Offline document generation – Configures the option to 
generate the master document offline. If you clear this option, the mater document 
gets generated normally. Offline generation can save the time of the provider that 
would have been spent waiting for the document to produce a copy in NextGen. 
The Master document cannot be disabled. 

• Set template other than the Master document and Chart Note to Offline document 
generation – Sets the document generation offline on the respective templates. By 
selecting this check box, you can also configure the Generate Document button in 
the Communication panel to submit the telephone_call_communication document 
for offline generation. 



Offline Document Processor



Offline Document Processor

Custom 

Trigger for 

sending a 

document to 

the ODP 



Q&A

847-490-6869

info@emedapps.com



THANK YOU!


